Joomla Update Issue using Sucuri & Sitelock - Ajax loading error.

A very common issue with upgrades in some environments is the Ajax loading - error on upgrade (Core Joomla upgrade).

If you already tried the usual causes like php post_max_size and max_exec_time and you haven't figured it out why it still doesn't work try our next solution below.

For the 3.7.x and following if you unzip the package via FTP you will break the site which will require some additional work, this is why we worked on a solution for this issue.


One of the causes we found at IDL WEB is that this issue might not rely on Joomla itself but on some CDN providers setup.

While debugging this issue for one of our clients when updating from 3.6.5 to 3.8, we noted it was caused by the Sucuri Firewall, which they use as part of the CDN/Security provider, the issue itself is the permissions to execute the script by the Joomla Installer.

This may happen with another CDN provider as well like SiteLock, Cloudflare, etc, depending on the firewall/security configuration.

For the Sucuri case which we worked on, Sucuri didn't even know this was happening with Joomla installations by the time we reach them, however, after bypassing the Sucuri proxy via hosts file modification
the Ajax error was gone and we were able to upgrade the Joomla.

For most CDN you may create page rules or rules that allow you to bypass the security/proxy/CDN or set up in development mode.

Keep up with us to know more of Joomla news/fixes!

And remember, if you require expert professional support with your Joomla CMS, we are here to help.

Per second billing & hourly support packages available.
Call us toll-free (844) JOOMLA-5  or   Request a free estimate

Tags: sucuri, sitelock, update, ajax